I want to thank everyone who contributed in the recents months. Compared to last year, the number of activities and PRs (including open ones) has increased dramatically. I would like to thank everyone who contributed to the project.
Personal note: Please keep in mind that this project is not funded or supported by a large company or similar organization. We work on the library in our free time after work. I appreciate your support, but please keep this in mind (including with other open-source projects).
What's Changed
- make stop-local-server fails with Docker due to unsupported -t option by @t2y in https://github.com/go-ldap/ldap/pull/584
- Fix panic on malformed LDAP responses by @Bahtya in https://github.com/go-ldap/ldap/pull/586
- chore(deps): bump github.com/Azure/go-ntlmssp from 0.1.0 to 0.1.1 in /v3 by @dependabot[bot] in https://github.com/go-ldap/ldap/pull/587
- Reject unescaped special characters in DN values per RFC 4514 by @t2y in https://github.com/go-ldap/ldap/pull/588
- v3/control: replace unchecked type asserts in DecodeControl with comma-ok by @c-tonneslan in https://github.com/go-ldap/ldap/pull/589
- fix(conn): parse ldapi:// URLs per RFC 4516 by @c-tonneslan in https://github.com/go-ldap/ldap/pull/590
- fix: decode Server Side Sorting controlValue as BER-encoded OCTET STRING per RFC 2891 by @ahanwhite in https://github.com/go-ldap/ldap/pull/593
- fix: generate digest-md5 cnonce with crypto/rand by @netliomax25-code in https://github.com/go-ldap/ldap/pull/594
- fix: escape quoted-string metacharacters in digest-md5 response by @netliomax25-code in https://github.com/go-ldap/ldap/pull/595
- fix: escape attribute and matching rule in DecompileFilter by @netliomax25-code in https://github.com/go-ldap/ldap/pull/596
- fix: set Result code when decoding ServerSideSortingResult control by @netliomax25-code in https://github.com/go-ldap/ldap/pull/597
- fix: reject trailing bytes in hex-encoded DN attribute value by @netliomax25-code in https://github.com/go-ldap/ldap/pull/598
- fix: synchronize writes to Conn.err with GetLastError by @netliomax25-code in https://github.com/go-ldap/ldap/pull/601
- unescape quoted-pair sequences in digest-md5 challenge parser by @netliomax25-code in https://github.com/go-ldap/ldap/pull/600
- fix: avoid uint16 overflow in gssapi UnmarshalWrapToken offset by @netliomax25-code in https://github.com/go-ldap/ldap/pull/602
- fix(conn): finish Unbind message context to prevent Close deadlock by @efd6 in https://github.com/go-ldap/ldap/pull/599
- fix: compare multi-valued RDN attributes as a multiset by @netliomax25-code in https://github.com/go-ldap/ldap/pull/604
- fix: respect backslash parity for escaped trailing space in DN value by @netliomax25-code in https://github.com/go-ldap/ldap/pull/603
- fix: skip empty referral sequence in getReferral by @netliomax25-code in https://github.com/go-ldap/ldap/pull/610
- fix: guard malformed paging control in DecodeControl by @netliomax25-code in https://github.com/go-ldap/ldap/pull/611
- handle linear whitespace in digest-md5 challenge parser by @netliomax25-code in https://github.com/go-ldap/ldap/pull/607
- chore: crypto update by @CameronJHall in https://github.com/go-ldap/ldap/pull/613
- fix: guard malformed responseValue in PasswordModify by @netliomax25-code in https://github.com/go-ldap/ldap/pull/614
- decode extended responseName by context class by @netliomax25-code in https://github.com/go-ldap/ldap/pull/605
- fix: prevent SearchAsync goroutine leak when context is cancelled during send by @t2y in https://github.com/go-ldap/ldap/pull/615
- fix: guard nil responseValue when parsing WhoAmI result by @johnweldon in https://github.com/go-ldap/ldap/pull/617
- fix: guard constructed-form attributeType in server-side sort decode by @johnweldon in https://github.com/go-ldap/ldap/pull/618
- chore: Update dependencies by @cpuschma in https://github.com/go-ldap/ldap/pull/620
New Contributors
- @Bahtya made their first contribution in https://github.com/go-ldap/ldap/pull/586
- @c-tonneslan made their first contribution in https://github.com/go-ldap/ldap/pull/589
- @ahanwhite made their first contribution in https://github.com/go-ldap/ldap/pull/593
- @netliomax25-code made their first contribution in https://github.com/go-ldap/ldap/pull/594
- @efd6 made their first contribution in https://github.com/go-ldap/ldap/pull/599
- @CameronJHall made their first contribution in https://github.com/go-ldap/ldap/pull/613
Full Changelog: https://github.com/go-ldap/ldap/compare/v3.4.13...v3.4.14